忘记密码?

一键登录

草根吧源码论坛

Discuz插件Zend加密请求加密方式混淆级别obfuscation

查看: 613|回复: 0

[Discuz!二次开发] Discuz插件Zend加密请求加密方式混淆级别obfuscation

[复制链接]

407

主题

2814

热度

2167

贡献

草根总版主

Rank: 8Rank: 8

联盟成员

发表于 2015-1-18 07:39:57 | 显示全部楼层 |阅读模式 | 百度  360  谷歌 
分享到:
本帖最后由 路人甲 于 2015-1-18 07:41 编辑

zend: Zend加密请求
请求开放平台协助加密指定的 PHP 脚本。如果您的开发者身份无此权限请不要包含此配置项,模板的主体文件不支持 Zend 加密。格式如下:        
<item id="zend">               
            <item id="method"><![CDATA[加密方式]]></item>               
            <item id="expires"><![CDATA[有效期]]></item>               
            <item id="files"><![CDATA[文件列表]]></item>        
</item>        
设置项变量含义
method开放平台使用的加密方式
zendenc52: 表示使用 PHP≤5.2 的方式加密
zendenc53: 表示使用 PHP≥5.3 的方式加密
expires加密脚本的使用有效期,单位为天,从审核通过后的日期开始计时。省略或 0 表示脚本永久有效
obfuscation代码混淆级别。省略或 0 表示不混淆 (慎用此功能,请在本地测试好后再上传)
files需要加密的脚本列表,每行写一个脚本名称,如“myrepeats.class.php”、“table/table_myrepeats.php”。包含动态变量的脚本不可被加密



帖子地址: 

ㄣ↘Catch me if you can!
回复

举报

发表回复

您需要登录后才可以回帖 登录 | 立即注册 新浪微博登陆 用百度帐号登录 一键登录:

本版积分规则

收藏帖子 返回列表 搜索
快速回复 返回顶部 返回列表